Router Installation and Configuration Manual/Basic Networking

From ImageStream Router Documentation

Jump to: navigation, search

Contents

Introduction

This page describes general network concepts that you must understand before you configure your ImageStream router. See the glossary linked to our Other Resources page for unfamiliar terms.

Domain Name Server (DNS)

The Domain Name Server (DNS) can be thought of as an interpreter. Humans can remember words better than long strings of numbers. When the Internet was developed, there was a need to merge people's natural ability to remember words with the computer's ability to understand numbers or bits, which is a series of ones and zeros. The DNS server translates a Web address such as http://www.imagestream.com to an IP address of 205.159.243.5. Every time you direct an internet search or enter a Web address, the DNS server is called to translate the address into an IP address that the computer can recognize and use. Without the DNS server, the Internet would not exist as it does today.

Network Addressing

ImageStream routers support packet routing using the IP protocol. The Internet Protocol (IP) is a packet-based protocol used to exchange data over computer networks. IP provides addressing and control information that allows data packets to be routed across networks.

IP Addressing

IP address descriptions are found in RFC 1166, Internet Numbers. The Network Working Group maintains and distributes the RFC documents. The American Registry for Internet Numbers (ARIN) assigns IP addresses and network numbers to Internet service providers (ISPs), who in turn provide to their customers a range of addresses appropriate to the number of host devices on their network. The sections that follow describe the various types of IP addresses, how addresses are given, and routing issues related to IP.

IP Address Notation

IP addresses are written in dotted decimal notation consisting of four numbers separated by dots (periods). Each number, written in decimal, represents an 8-bit octet (sometimes informally referred to as a byte) giving each number a range of 0 through 255, inclusive. When strung together, the four octets form the 32-bit IP address. Table 1 shows 32-bit values expressed as IP addresses. The largest possible value of a field in dotted decimal notation is 255, which represents an octet where all the bits are 1s.

IP Address Classes

IP addresses are generally divided into different classes of addresses based on the number of hosts and subnetworks required to support the hosts. As described in RFC 1166, IP addresses are 32-bit quantities divided into five classes. Each class has a different number of bits allocated to the network and host portions of the address. For this discussion, consider a network to be a collection of computers (hosts) that have the same network field values in their IP addresses. The concept of classes is being made obsolete by classless interdomain routing (CIDR).
Instead of dividing networks by class, CIDR groups them into address ranges. A network range consists of an IP address prefix and a netmask length. The address prefix specifies the high-order bits of the IP network address. The netmask length specifies the number of high-order bits in the prefix that an IP address must match to fall within the range indicated by the prefix.
For example, 192.168.42.x describes a Class C network with addresses ranging from 192.168.42.0 through 192.168.42.255. CIDR uses 192.168.42.0/24 to describe the same range of addresses. RIP version 1 is an example of a protocol that uses address classes. OSPF and BGP-4 are examples of protocols that do not use address classes.
Table 1 - IP Address Notation
32-Bit Value Dotted Decimal Notation
01100100.01100100.01100100.00001010 100.100.100.10
11000011.00100000.00000100.11001000 195.32.4.200

Class A Addresses

The class A IP address format allocates the highest 8 bits to the network field and sets the highest-priority bit to 0 (zero). The remaining 24 bits form the host field. Only 126 class A networks can exist (0 is reserved, and 127 is used for loopback networks), but each class A network can have almost 17 million hosts. No new class A networks can be assigned at this time.
For example:

          10.100.232.1
          __ _________
          /      \
         /        \
      Network      \
      address    Host address

Class B Addresses

The class B IP address format allocates the highest 16 bits to the network field and sets the two highest-order bits to 1 and 0, providing a range from 128 through 191, inclusive. The remaining 16 bits form the host field. More than 16,000 class B networks can exist, and each class B network can have up to 65,534 hosts.
For example:

          10.10.232.201
          _____ _______
            /      \
           /        \
       Network       \
       address    Host address

Class C Addresses

The class C IP address format allocates the highest 24 bits to the network field and sets the three highest-order bits to 1, 1, and 0, providing a range from 192 through 223, inclusive. The remaining 8 bits form the host field. More than two million class C networks can exist, and each class C network can have up to 254 hosts.
For example:

          10.10.12.121
          ________ ___
             /      \
            /        \
       Network        \
       address    Host address

Class D Addresses

The class D IP address format was designed for multicast groups, as discussed in RFC 988. In class D addresses, the 4 highest-order bits are set to 1, 1, 1, and 0, providing a range from 224 through 239, inclusive. Class D addresses are currently used primarily for the multicast backbone (MBONE) of the Internet.

Class E Addresses

The class E IP address is reserved for future use. In class E addresses, the 4 highest-order bits are set to 1, 1, 1, and 1. Routers currently ignore class E IP addresses.

Reserved IP Addresses

Some IP addresses are reserved for special uses and cannot be used for host addresses. Table 2 lists ranges of IP addresses and shows which addresses are reserved, which are available to be assigned, and which are for broadcast.
Table 2 - Reserved and Available IP Addresses
Class IP Address Status
A 0.0.0.0 Reserved
1.0.0.0 through 126.0.0.0 Available
127.0.0.0 Reserved
B 128.0.0.0 Reserved
128.1.0.0 through 191.254.255.255 Available
191.255.0.0 Reserved
C 192.0.0.0 Reserved
192.0.1.0 through 223.255.254.255 Available
223.255.255.0 Reserved
D 224.0.0.0 through 239.255.255.255 Multicast group addresses
E 240.0.0.0 through 255.255.255.254 Reversed
255.255.255.255 Broadcast

Private IP Networks

RFC 1597 reserves three IP network addresses for private networks. The addresses 10.0.0.0/8, 192.168.0.0/16, and 172.16.0.0/20 can be used by anyone for setting up their own internal IP networks.

IP Address Conventions

If the bits in the host portion of an address are all 0, that address refers to the network specified in the network portion of the address. For example, the class C address 192.31.7.0 refers to a particular network. Historically, this address was used as a broadcast.
The standard for broadcast is high, which uses all 1s in the host portion (for example, 192.168.1.255); however, many networks still use all 0s. The ImageStream router can be configured either way and should be set to match the other systems on your network. Note: Do not assign an IP address with all 0s or all 1s in the host portion of the address to a host on the network, because these are reserved as broadcast addresses. With CIDR, networks are specified with an IP prefix and netmask length--for example, 172.16.0.0/16, 192.168.1.0/24, or 192.168.200.240/28.

Netmasks

A netmask is a four-octet number that identifies either a supernetwork (supernet) or a subnetwork (subnet). A netmask that designates a subnet is called a subnet mask.

Using Subnet Masks to Create IP Subnets

Subnet masks are used to divide networks into smaller, more manageable groups of hosts known as subnets. Subnetting is a scheme for imposing a hierarchy on hosts on a single physical network. The usual practice is to use the first few bits in the host portion of the network address for a subnet field. RFC 950, Internet Standard Subnetting Procedure, describes subnetting.
A subnet mask identifies the subnet field of a network address. This mask is a 32-bit number written in dotted decimal notation with all 1s (ones) in the network and subnet portions of the address, and all 0s (zeros) in the host portion. This scheme allows for the identification of the host portion of any address on the network. Table 3 shows the subnet masks you can use to divide a class C network into subnets.
Table 3 - Subnet Masks for a Class C Network
Length (Subnet Bits) Number of Subnets Number of Hosts per Subnet Hexadecimal Subnet Mask Dotted Decimal Subnet Mask
24 1 254 0xffffff00 255.255.255.0
25 2 126 0xffffff80 255.255.255.128
26 4 62 0xffffffc0 255.255.255.192
27 8 30 0xffffffe0 255.255.255.224
28 16 14 0xfffffff0 255.255.255.240
29 32 6 0xfffffff8 255.255.255.248
30 64 2 0xfffffffc 255.255.255.252
32 256 1 0xffffffff 255.255.255.255

Understanding the Network Interface Configuration File (wan.conf)

wan.conf is the primary configuration file used by ImageStream's Inetics driver component architecture and the management utility configmgr. configmgr uses the wan.conf file to manage the configuration of all Inetics interfaces. See the Command Reference for more information on commands supported by configmgr and Inetics.
The default wan.conf file is:
     ! 
     version 2.00 
     ! 
     interface Ethernet0 
     ip address 10.10.199.199 255.0.0.0
     !
     interface Serial0 
     shutdown 
     description Port 0 
     encapsulation hdlc 
     ip address 192.168.10.1 255.255.255.252
     !
     # Set the default route via Serial0 using the device #ip route add 0.0.0.0/0 dev Serial0 
     # Set the default route via Serial0 using an IP 
     #ip route add default via 192.168.10.2 
     ! 
     end 
The values in the default file are explained below.
version 2.00 - Denotes the version number of the configuration file and driver set. This value is set by ImageStream and should not be changed or modified.
interface Ethernet0 - Denotes the start of the configuration section for the first Ethernet device in your system. All commands that follow this line until the next ! mark will be applied to Ethernet0.
ip address 10.10.199.199 255.0.0.0 - Specifies the IP address and netmask for Ethernet0.
!, end - Signifies the end of a configuration section or the end of the wan.conf file. You must include a "!" to delimit each section of the configuration file and an "end" statement at the end of the file.
interface Serial0 - Denotes the start of the configuration section for the first Serial port in your system. All commands that follow this line until the next ! mark will be applied to Serial0.
shutdown - Instructs the router not to start this port when Inetics is started or reloaded.
description Port 0 - Sets a description for this device. The description is optional used for reporting purposes in other utilities. Setting a value here does not affect the operation of the port.
encapsulation hdlc - Specifies the Cisco HDLC protocol for this serial port.
ip address 192.168.10.1 255.255.255.252 - Specifies the IP address and netmask for Serial0.
# Set the default route via Serial0 using the device - A comment inserted in the configuration file. Lines that begin with # or "!" are ignored by Inetics when starting or reloading configurations.
#ip route add 0.0.0.0/0 dev Serial0 - A route statement setting the default route to the Serial0 device. Note that this command is commented out, so it will be ignored by Inetics.
#ip route add default via 192.168.10.2 - A route statement setting the default route to the IP address of 192.168.10.2. Note that this command is commented out, so it will be ignored by Inetics. This command also uses the alternate default route designator of default instead of the numeric 0.0.0.0/0. The designators are equivalent.

Understanding WAN's

The following section describes the basic WAN's implementation and operation.
WAN ports are used for high-speed dedicated connections between two local area networks (LANs). Once a connection is established between two sites, a wide area network (WAN) is achieved. WAN connections can be achieved through the use of dedicated leased lines such as T1, E1 or higher bandwidth lines, SONET/SDH connections, ATM connections, Frame Relay connections, or ISDN lines. Connection rates can range from 9600bps to 2.048Mbps (E1) to 2.488Gbps (OC-48). ImageStream routers support these connection types using one or more serial ports with or without integrated CSU/DSUs.
All WAN port connections are very similar and are represented in the diagram below.
WAN.png
For most applications, a dedicated line connects two routers, each located on a separate remote network. The following examples describe various uses for synchronous ports.
Routing over Leased Lines. A serial port with or without integrated CSU/DSUs can be used to connect to synchronous leased lines from 9600bps to T1 (1.544Mbps) or E1 (2.048Mbps) to DS3 (44.736Mbps) or E3 (34.368Mbps) for continuous operation. Synchronous optical network (SONET) or Synchronous Digital Hierarchy (SDH) interfaces use optical instead of copper wiring and commonly operate at speeds from OC-3/STM-1 (155.52Mbps) to OC-48/STM-16 (2.488Gbps) and higher. A channel service unit/digital service unit (CSU/DSU) must be attached to the serial port, or integrated into the serial card. For more information about configuring cards with integrated CSU/DSU's, see Chapter 8, "Configuring an Integrated CSU/DSU WAN Interface."
Routing over ATM. ATM (asynchronous transfer mode) is a dedicated-connection switching technology that organizes digital data into 53-byte cell units (48 bytes of data, 5 bytes of overhead) and transmits them over a physical medium using digital signal technology. Individually, a cell is processed asynchronously relative to other related cells. Like frame relay, two advantages over a leased line network are lower cost and the ability to have multiple virtual circuits (VC's) come into a single physical port. It is especially popular for DSL service and hub-and-spoke network arrangements. However, unlike frame relay, ATM is designed for easy implementation in hardware (rather than software) and is designed for optical links at higher speeds. For more information about configuring ATM, see Chapter 9, "Configuring an ATM Interface."
Routing over Frame Relay. Frame Relay provides connectivity using a packet switched network. Its two advantages over a leased line network are lower cost and the ability to have multiple permanent virtual circuits (PVC's) come into a single physical port. It is especially popular for hub-and-spoke network arrangements. For example, a dozen field offices with T1 or fractional T1 Frame Relay connections can connect to a central office using a single DS3, fractional DS3 or T1 Frame Relay connection. The central office requires only one CSU/DSU and serial port on the router, instead of twelve. For more information about configuring frame relay, see Chapter 10, "Configuring a Frame Relay Interface."
Routing over ISDN. Integrated Services Digital Network (ISDN) provides fast dial-up connectivity for applications where the expense of a dedicated Frame Relay, ATM or leased line connection is not appropriate for the amount and nature of the traffic. For more information about ISDN Basic Rate Interface (BRI) connections, see Chapter 11, "Configuring an ISDN BRI Interface."
Personal tools
Router software releases