Mult-Router L2TP LNS Configuration

From ImageStream Router Documentation

Jump to: navigation, search

For load balancing and redundancy the LAC normally is configured with a list of LNS IPs. Often LACs in a certain region will be configured to send to a particular cluster of LNS IPs. The LAC will round-robin between the LNS routers automatically as new client PPP sessions are established. If an LNS goes down all PPP sessions on that LNS will terminate or eventually time out and re-establish on other active LNSs in the cluster. The LAC will cache the status of previous LNS connection attempts.

This example shows how to configure the router as part of a cluster of router acting as an LNS. This configuration uses Ospf to distribute routing information between a distribution router and between the routers in the cluster.

L2TP Configuration

The L2TP configuration is very simple: for more information on LNS configuration see the following manual page.

Configuring L2TP as an LNS


!
interface Loopback0
 ip address 60.104.8.1 255.255.255.255
!
interface Tunnel0
 description vlan1220
 tunnel mode l2tp
 tunnel peer name default
 tunnel local name isnet
 tunnel key h18sJ98l
 tunnel virtual-template 1
!
interface Virtual-Template1
 ip unnumbered Loopback0
 peer default ip pool pool1
 radius-server host 205.159.243.5 acct-port 1813 auth-port 1812 key password
 ppp authentication pap chap
 mtu 1500
!
ip local pool pool1 60.104.8.2 60.104.11.254
ip local pool pool1 60.104.12.2 60.104.15.254
ip name-server 205.159.243.5
ip name-server 205.159.243.6
!

For this example the telco would specify our local name as gbnet and our password as h18sJ98l. The telco also specified the use of VLAN 1220 and our IP range of 10.15.0.2 - 10.15.0.6 for our LNS cluster. Our telco also specifies a 1600 byte MTU on the GigE port to avoid IP fragmentation of large frames being tunneled.

# L2TP sessions come in to us on VLAN 1220 via Ethernet1. Bell uses a 1600 byte MTU on their GigE
# interfaces to avoid IP fragmentation overhead when tunneling large frames.
!
interface Ethernet1
 no ip address
 speed 1000
 duplex full
 mtu 1600
!
interface Ethernet1.1220
 mtu 1600
 description vlan1220 3AGAS
 ip address 10.15.0.2 255.255.255.248
!

OSPF Configuration

The goal of the OSPF configuration is to export routing information to a traffic distribution router and between the other routers in the LNS cluster. In this example the routers are connected to the distribution router via Ethernet interface Ethernet0 with an ip address of 60.104.7.2/24. In the example below we use the same ip address ranges as the LNS example above.

!
router ospf
 redistribute connected
 network 60.104.7.0/24 area 0.0.0.0
 distribute-list PPP_OUT out connected
!
access-list PPP_OUT permit 60.104.8.0/22
access-list PPP_OUT permit 60.104.12.0/22
access-list PPP_OUT deny any
!
Personal tools
Router software releases