ATM Dsl Aggregation RFC-1483

From ImageStream Router Documentation

Jump to: navigation, search

Contents

Introduction

Typical Network configuration
Dsl Aggregation can be accomplished via several methods. The method outlined on this page describes dsl aggregation using Multiprotocol Encapsulation over ATM. This is commonly referred to as ATM route-bridge or Rfc 1483 bridging.

Requirements

  • The router must be running at least Imagestream Linux 4.2.0
  • Be sure to have the correct Pvc information from your provider. An allocated an IP network for your Dsl clients and chose the IP address for the router out of that subnet.
  • The connection from your provider must be ATM.
  • The customer end-point devices need to configured to run in ATM Route-Bridge mode, the correct Pvc information will likely be different from the Pvc on the Isp side. Verify the correct settings with your Dsl provider.

Sample Configuration

In this example, we are going to assume the following network settings.

  • The Router has a WAN IP address of 205.159.243.1 with a netmask of 255.255.255.0
  • The Dsl Customer with VPI 1 and VCI 101 has a description of High Speed User
  • This customer has an IP address of 205.159.243.10
  • This customer has a download bandwidth of 6Mbit
  • The correct ATM QoS settings for this Pvc is VBR at 6Mbit
  • The Dsl Customer with VPI 1 and VCI 101 has a description of Low Speed User
  • This customer has an IP address of 205.159.243.11
  • This customer has a download bandwidth of 384Kbit
  • The correct ATM QoS settings for this Pvc is VBR at 384Kbit
  • The interface Serial0.200 is the start of a PVC Range group of Midspeed Users
  • The "range pvc" command sets up 40 interfaces Serial0.200-Serial0.240
  • The customers in this group have a download bandwith of 1.5Mbit
  • The correct ATM QoS settings for these Pvc's is VBR at 1.5Mbit
 !
  interface Loopback0
  ip address 205.159.243.1 255.255.255.0
 !
 interface Serial0
  description ATM0
  encapsulation atm
 !
 interface Serial0.101
  description High Speed User
  ip unnumbered Loopback0
  atm route-bridged ip
  pvc 1/101
  encapsulation aal5snap
  bandwidth 6000000
  vbr
 !
  ip route 205.159.243.10 255.255.255.255 Serial0.101
 !
 interface Serial0.102
  description Low Speed User
  ip unnumbered Loopback0
  atm route-bridged ip
  pvc 1/102
  encapsulation aal5snap
  bandwidth 384000
  vbr
 !
  ip route 205.159.243.11 255.255.255.255 Serial0.102
 !
 interface Serial0.200
  description Mid Speed Group
  ip unnumbered Loopback0
  atm route-bridged ip
  range pvc 1/200 1/240
  encapsulation aal5snap
  bandwidth 1500000
  vbr
 !
  ip route 205.159.243.200 255.255.255.255 Serial0.200
  ip route 205.159.243.201 255.255.255.255 Serial0.201
  ip route 205.159.243.210 255.255.255.255 Serial0.210
 !
 end
 !

Configuration Details

Important Details of this configuration.
  • The router will automatically create a bridge interface for each configured Serial interface, these interfaces will be named brSerial****. For example Serial0.101 will have an automatically generated bridge interface named brSerial0.101.
  • The combination of the "bandwidth" Command and the "vbr" command prevents the Pvc from transmitting at a rate greater than the set bandwidth. These commands are required in most real world configurations due to ATM QoS in Dsl providers ATM networks.
Personal tools
Router software releases